Our team has identified a PDU issue affecting a portion of the C8 area at our Ohio 2 facility. The onsite technicians are actively addressing the problem, and we will work to restore full operations as quickly as possible. We appreciate your continued patience and understanding as we resolve this matter.
Posted Nov 24, 2025 - 14:20 UTC
Update
The site team in our Ohio 2 Facility continues to work on resolving the issues with the exhaust fans on C9 and has identified similar issues in C3 that they too are also working on. We hope to have this resolved soon. We thank you for your continued patience and understanding.
Posted Nov 19, 2025 - 15:55 UTC
Identified
Our Ohio 2 facility has identified issues with the exhaust fans on a portion of the site (C9). The onsite team will bring the miners back online as soon as this is resolved. We appreciate your patience and cooperation.