Manitoba 2 Outage
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted May 29, 2023 - 07:18 UTC
Investigating
We are currently investigating this issue
Posted May 27, 2023 - 21:26 UTC
This incident affected: Manitoba 2, Canada.