Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 02, 2024 - 21:30 UTC
Scheduled
The Indiana 2 facility is curtailing today 12/02 from 4:30 PM to 8 PM EST. The onsite team will bring the miners back online as soon as power is fully restored. We appreciate your patience and cooperation.
Posted Dec 02, 2024 - 14:25 UTC
This scheduled maintenance affected: Indiana 2, United States.