Indiana 1, Indiana 2, and Indiana 3 - Scheduled Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted May 07, 2026 - 16:41 UTC

Identified

The local power authority has issued a notice to curtail. The mining facilities will power down between the hours of 07:40 AM to 11:00 AM EST, 05/07/2026.

Indiana 1
Indiana 2
Indiana 3

Our technicians will bring miners back online as soon as the curtailment period is complete. Thank you for your patience and understanding.
Posted May 07, 2026 - 15:10 UTC
This incident affected: Indiana 1, United States, Indiana 2, United States, and Indiana 3.