Minnesota 1 - Maintenance
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Apr 10, 2024 - 16:39 UTC
Identified
Minnesota 1 will perform a container upgrade today. Units will see slight downtime throughout the day.
Our onsite team will restore the miners as soon as the maintenance period has ended.
We appreciate your cooperation.
Posted Apr 10, 2024 - 15:49 UTC
This incident affected: Minnesota, United States.