Maintenance canceled due to poor weather. Rescheduled for Tuesday next week.
Posted Aug 30, 2024 - 13:39 UTC
Update
Texas 5 will continue their site maintenance today, 08/30. We appreciate your cooperation.
Posted Aug 30, 2024 - 13:07 UTC
Identified
Texas 5 will be shutting down a portion of the site for maintenance today, 08/29. Our on-site team will bring the miners back online as soon as the maintenance is complete. We appreciate your cooperation.