Iowa 4 - Scheduled Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Jun 11, 2025 - 11:56 UTC

Identified

The Iowa 4 facility will undergo curtailment today, June 10th, starting 8:00 AM. The onsite team will restore the miners as soon as power returns. Thank you for your patience and understanding.
Posted Jun 10, 2025 - 07:19 UTC
This incident affected: Iowa 4, United States.