North Dakota - Maintenance

Incident Report for Compass Mining

Update

The site-wide maintenance has been completed, but due to ongoing electrical work, some units remain offline. The onsite team will bring the miners back online as soon as the issue is resolved.

Thank you once again for your kind understanding.
Posted Nov 13, 2025 - 19:00 UTC

Identified

The Facility is scheduled for site-wide maintenance today, November 12, 2025.The onsite team will bring the miners back online as soon as this is resolved.

We appreciate your patience and understanding.
Posted Nov 12, 2025 - 14:55 UTC
This incident affects: North Dakota, United States.