Texas 5 and Texas 5 (2) - Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Apr 28, 2026 - 07:41 UTC

Identified

The local power authority has issued a notice to curtail due to price volatility. Our technicians will restore operations as soon as the curtailment period concludes. Thank you for your patience and understanding.
Posted Apr 28, 2026 - 02:13 UTC
This incident affected: Texas 5, United States and Texas 5 (2).