Minnesota 1 - Scheduled Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Jun 29, 2025 - 13:17 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 29, 2025 - 13:17 UTC

Identified

The Minnesota facility will undergo a scheduled curtailment today, June 28th, from 5:00 PM to 11:00 PM Central Time. There is a possibility that the curtailment may start early or may be extended. Once power is restored, the onsite team will promptly bring the miners back online. We appreciate your patience and understanding.
Posted Jun 28, 2025 - 11:23 UTC
This incident affected: Minnesota, United States.