Nebraska 2 - Outage

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Mar 20, 2025 - 04:05 UTC

Update

Update: The Nebraska 2 facility is experiencing a Power Outage due to the Snowstorm. ISP is impacted as well. The onsite team will bring the miners back online as soon as power and connectivity is fully restored. We appreciate your patience and cooperation.
Posted Mar 19, 2025 - 13:49 UTC

Identified

The Nebraska 2 facility is impacted by a snowstorm. A blizzard warning is in effect from 1:00 AM to 2:00 PM CDT. We will continue to monitor the situation and provide updates as necessary.
Posted Mar 19, 2025 - 12:16 UTC
This incident affected: Nebraska, United States.