Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 26, 2024 - 23:00 UTC
Scheduled
Ontario will be shutting down for seasonal maintenance. Our on-site team will bring the miners back online as soon as the maintenance is complete. We appreciate your cooperation.
Posted Nov 26, 2024 - 16:08 UTC
This scheduled maintenance affected: Ontario, Canada.