150 Units at Iowa 3 and 25 Units at Iowa 2 are impacted by the ongoing maintenance.
Posted Mar 24, 2025 - 12:35 UTC
Identified
The site has encountered an issue with one of the main breakers. Our onsite team will schedule an electrician to visit the site once the weather improves, as the site is currently experiencing severe winds and tornado warnings.
Posted Mar 19, 2025 - 14:05 UTC
This incident affected: Iowa 2, United States and Iowa 3, United States.