Minnesota 1 - Scheduled Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Nov 03, 2025 - 12:52 UTC

Identified

The local power authority has issued a notice to curtail. The mining facility will power down from 6:00 AM to 8:00 AM and 6:00 PM to 7:00 PM Central Time today, October 31, 2025.

Our technicians will bring miners back online as soon as the curtailment period is complete. Thank you for your patience.
Posted Oct 31, 2025 - 09:10 UTC
This incident affected: Minnesota 1, United States.