Iowa 3 - Partial Outage

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Mar 19, 2025 - 12:57 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 19, 2025 - 12:30 UTC

Investigating

We are currently investigating this issue.
Posted Mar 19, 2025 - 07:39 UTC
This incident affected: Iowa 3, United States.