Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 15, 2025 - 17:00 UTC
Scheduled
The Ontario1 facility is curtailing today, 01/15 from 12PM to 2PM EST. The onsite team will bring the miners back online as soon as power is fully restored. We appreciate your patience and cooperation.
Posted Jan 15, 2025 - 14:31 UTC
This scheduled maintenance affected: Ontario, Canada.