Texas 1 - Electrical Maintenance
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Nov 06, 2024 - 02:20 UTC
Identified
This is a notification of planned electrical maintenance that may briefly affect mining operations.

When: Tuesday, November 5th, beginning at 7:00 AM Central Time

We understand that any downtime can be impactful, and we are working to minimize the duration of the maintenance.
Posted Nov 05, 2024 - 01:44 UTC
This incident affected: Texas 1, United States.