Texas 3 - Outage
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Apr 19, 2024 - 09:26 UTC
Update
We are continuing to investigate this issue.
Posted Apr 18, 2024 - 13:52 UTC
Update
We are continuing to investigate this issue.
Posted Apr 18, 2024 - 02:34 UTC
Update
We are continuing to investigate this issue.
Posted Apr 18, 2024 - 00:24 UTC
Investigating
We are currently investigating this issue.
Posted Apr 02, 2024 - 15:40 UTC
This incident affected: Texas 3, United States.