Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 03, 2023 - 16:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Oct 03, 2023 - 08:29 UTC
Scheduled
The upgrade is scheduled to begin at 1200 EST with a window until 1800 EST. Technicians are standing by to bring all miners back online as soon as maintenance is completed.
Posted Oct 03, 2023 - 08:27 UTC
This scheduled maintenance affected: Texas 5, United States.