Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 14, 2025 - 17:11 UTC
Scheduled
Our Ohio 2 facility has ongoing maintenance on a portion of the site (C1), doing filter swaps. The onsite team will bring the miners back online as soon as power is fully restored. We appreciate your patience and cooperation.
Posted May 14, 2025 - 17:10 UTC
This scheduled maintenance affected: Ohio 2, United States.