Minnesota 1 - Scheduled Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Jan 15, 2026 - 10:11 UTC

Identified

The MN1 site is currently undergoing partial curtailment. Our technicians will bring miners back online as soon as the curtailment period is complete.
Posted Jan 14, 2026 - 12:21 UTC
This incident affected: Minnesota 1, United States.