(52x) South Carolina - Major Outage
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Feb 12, 2023 - 09:31 UTC
Investigating
The facility experienced a power surge which caused an issue with the transformer. They are actively working to resolve this and restore all miners.
Posted Feb 08, 2023 - 05:32 UTC