Minnesota 1 - Scheduled Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Mar 20, 2025 - 03:58 UTC

Identified

The Minnesota facility will curtail March 19th, from 5:00 PM to 7:00 AM Central time. These times may change. The onsite team will restore the miners as soon as power returns. Thank you for your patience.
Posted Mar 19, 2025 - 06:51 UTC
This incident affected: Minnesota, United States.