We apologize for the inconvenience. The site will remain curtailed until 7 AM Central Time on April 3rd, although these timings are subject to change. The onsite team will promptly restore the miners as soon as power is back. We appreciate your understanding and thank you for your cooperation.
Posted Apr 03, 2025 - 02:43 UTC
Update
The power grid continues to be affected by weather conditions in the area. A major curtailment is planned from April 2, 12:00 AM, to April 3, 12:00 AM Central Time.
Posted Apr 02, 2025 - 07:11 UTC
Identified
The Minnesota facility will curtail April 1st, from 4:00 AM to 12:00 AM Central time. These times may change. The onsite team will restore the miners as soon as power returns. Thank you for your patience.