Texas 5 - Site Maintenance
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Jan 20, 2025 - 14:12 UTC
Identified
Our Texas 5 facility will undergo scheduled infrastructure maintenance from January 13 to January 19, 2025. During this period, the entire facility will be shut down to allow for critical improvements. Our on-site team will bring the miners back online as soon as the maintenance is complete. We appreciate your cooperation.
Posted Jan 10, 2025 - 16:54 UTC
This incident affected: Texas 5, United States.