Ohio 2 - Maintenance

Incident Report for Compass Mining

Identified

Facility Update: The Site team has finished filter cleaning on the C3 container and moved to the C6 containers for filter cleaning. We truly appreciate your patience and understanding during this time.
Posted Jul 17, 2025 - 12:36 UTC

Investigating

Our Ohio 2 facility is experiencing ongoing maintenance on a portion of the site (C3) for filter cleaning. The onsite team will bring the miners back online as soon as this is resolved. We appreciate your patience and cooperation.
Posted Jul 15, 2025 - 17:05 UTC
This incident affects: Ohio 2, United States.