Minnesota 1 - Scheduled Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Dec 02, 2025 - 02:18 UTC

Update

The Minnesota 2 site is currently under curtailment. Our technicians will restore the miners as soon as each curtailment period concludes.
Posted Dec 01, 2025 - 13:22 UTC

Identified

The local power authority has issued a notice to curtail. The mining facility will power down today, December 1, 2025, from 6:00 AM to 8:00 AM and 3:00 PM to 7:00 PM .

Our technicians will bring the miners back online as soon as each curtailment period is complete. Thank you for your understanding.
Posted Dec 01, 2025 - 06:49 UTC
This incident affected: Minnesota 1, United States.