Iowa 3 - Partial Outage
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Nov 17, 2024 - 23:10 UTC
Identified
Iowa 3 is currently experiencing a partial outage. Our on-site team will bring the miners back online as soon as the outage is resolved. We appreciate your cooperation.
Posted Nov 14, 2024 - 13:43 UTC
This incident affected: Iowa 3, United States.