Minnesota 1 - Scheduled Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Mar 12, 2025 - 04:21 UTC

Identified

The Minnesota facility will curtail March 11th, from 9:00 AM to 11:00 AM Central time. These times may change. The onsite team will restore the miners as soon as power returns. Thank you for your patience.
Posted Mar 11, 2025 - 11:33 UTC
This incident affected: Minnesota, United States.