Texas 4 - Outage

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Sep 24, 2023 - 01:30 UTC

Investigating

We are currently investigating this issue.
Posted Sep 24, 2023 - 01:01 UTC