Manitoba 6 Partial Outage

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Oct 07, 2023 - 00:16 UTC

Investigating

We are currently investigating this issue.
Posted Oct 03, 2023 - 12:41 UTC
This incident affected: Manitoba 6, Canada.