Texas 5 - Maintenance
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Jul 23, 2024 - 17:05 UTC
Identified
The Texas 5 facility will shut down a portion of the facility for maintenance and site improvements at 11AM CST. Our onsite team will bring the miners back online as soon as power is fully restored. We appreciate your cooperation.
Posted Jul 23, 2024 - 16:15 UTC
This incident affected: Texas 5, United States.