North Dakota - Partial Outage

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Jul 30, 2025 - 19:24 UTC

Identified

Container #19 at the facility is currently experiencing an issue, and our on-site technicians are actively working to resolve it.

Thank you for your patience and understanding.
Posted Jul 30, 2025 - 12:44 UTC
This incident affected: North Dakota, United States.