(cal) Kentucky Partial Outage
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Sep 23, 2022 - 12:25 UTC
Identified
The facility had a power loss this morning. Power was restored to the substation, and they are working on restoring the power to the site and bringing units back online.
Posted Sep 22, 2022 - 17:24 UTC
Investigating
We are currently investigating this issue.
Posted Sep 22, 2022 - 17:14 UTC