Nevada 1 Temp Miners - Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Oct 04, 2023 - 00:09 UTC

Investigating

The facility hosting the Nevada 1 temp miners is currently curtailing due to grid demands.
Posted Oct 03, 2023 - 21:20 UTC