Texas 5 - Maintenance
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Sep 04, 2024 - 09:20 UTC
Identified
Texas 5 will be shutting down a portion of the site for maintenance today, 09/03. Our on-site team will bring the miners back online as soon as the maintenance is complete. We appreciate your cooperation.
Posted Sep 03, 2024 - 12:51 UTC
This incident affected: Texas 5, United States.