Minnesota 1 - Relocation

Incident Report for Compass Mining

Update

The facility relocation remains in progress. Over a hundred units have been cleaned and tested; several redeployed, with the rest awaiting racking. Customers with miners still at the service center will be notified if repairs are needed.
Posted Jul 01, 2026 - 06:28 UTC

Identified

The miners at the Minnesota 1 facility are now being prepared for deracking, and the relocation process is actively underway. Updates will be shared as new information becomes available.

Thank you for your continued cooperation.
Posted Jun 02, 2026 - 14:04 UTC
This incident affects: Minnesota 1, United States.