Texas 3 Outage
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted May 22, 2023 - 21:46 UTC
Identified
The site is experiencing a network outage. Onsite teams are working to resolve as soon as possible.
Posted May 22, 2023 - 18:24 UTC
Investigating
We are currently investigating this issue.
Posted May 22, 2023 - 18:15 UTC
This incident affected: Texas 3, United States.