Texas 5 - Power Curtailment
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Jan 21, 2025 - 13:50 UTC
Identified
The Texas 5 facility is currently curtailing due to high electricity demand caused by the cold front. We appreciate your continued patience and understanding.
Posted Jan 20, 2025 - 14:16 UTC
This incident affected: Texas 5, United States.