Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 20, 2024 - 19:16 UTC
Scheduled
Ohio 2 will be shutting down a portion of the site (C7). Our on-site team will bring the miners back online as soon as the maintenance is complete. We appreciate your cooperation.
Posted Nov 20, 2024 - 19:15 UTC
This scheduled maintenance affected: Ohio 2, United States.