North Dakota 2 - Partial Outage

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Aug 25, 2025 - 12:18 UTC

Identified

Due to elevated local temperatures, the facility is currently experiencing partial curtailment. Not all miners are affected. If your miner is offline and does not return online once conditions stabilize, please submit a support request, and our Remote Monitoring Team will investigate further.
Posted Aug 21, 2025 - 12:32 UTC
This incident affected: North Dakota, United States.