Iowa 2 and Iowa 3 - Power Curtailment
Incident Report for Compass Mining
Resolved
This incident has been resolved.
Posted Dec 06, 2024 - 11:14 UTC
Identified
The Iowa 2 and Iowa 3 facility will be partially curtailing today December 5 from 6:00 AM to 9:00 AM CST and again from 3:00 PM to 9:00 PM CST.
The onsite team will bring the miners back online as soon as power is fully restored. We appreciate your patience and cooperation.
Posted Dec 05, 2024 - 10:13 UTC
This incident affected: Iowa 2, United States and Iowa 3, United States.