Nevada 1 Temp Miners - Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Oct 02, 2023 - 03:02 UTC

Investigating

The facility hosting the Nevada 1 temp miners is currently curtailing due to grid demands.
Posted Oct 01, 2023 - 19:07 UTC