Texas 3 - Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Sep 21, 2023 - 01:51 UTC

Investigating

The Texas 3 facility is currently curtailing due to grid demands.

ETA for re-energization is 8:00 PM CST.
Posted Sep 20, 2023 - 20:54 UTC