Iowa 3 - Site Maintenance
Incident Report for Compass Mining
Update
Due to an electrical issue on-site, the energization has been delayed until the end of this week. Our on-site team is currently waiting for the delivery of the necessary parts, which are expected to arrive this week. We will provide further updates once the issue is resolved.
Posted Jan 13, 2025 - 15:34 UTC
Update
An additional 300 units are affected by the maintenance. The onsite team will bring the miners back online as soon as the maintenance is complete.
Posted Jan 03, 2025 - 14:31 UTC
Identified
The Iowa 3 facility will be performing maintenance and consolidating miners between December 26, 2024 and January 5, 2025. Around 10% of the facility (400 miners) will be impacted by this activity. The onsite team will bring the miners back online as soon as the maintenance is complete. We appreciate your patience and cooperation.
Posted Dec 23, 2024 - 16:03 UTC
This incident affects: Iowa 3, United States.