Texas 5 - Power Outage

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Feb 16, 2026 - 05:16 UTC

Update

The site has been re-energized, but a portion remains offline as the transformer repair is still in progress.
Posted Feb 10, 2026 - 09:44 UTC

Identified

The facility has powered down to address a transformer issue. We will provide an update once the issue has been resolved and the site has been re-energized. Thank you for your patience and understanding.
Posted Feb 09, 2026 - 15:10 UTC
This incident affected: Texas 5, United States.