Minnesota 2 - Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted May 08, 2026 - 10:43 UTC

Identified

The Minnesota 2 facility is currently undergoing curtailment. Our technicians will restore miners to full operation as soon as the curtailment period concludes. We appreciate your patience and understanding during this time.
Posted May 08, 2026 - 03:19 UTC
This incident affected: Minnesota 2, United States.