North Dakota - Partial Outage

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Aug 06, 2025 - 22:42 UTC

Identified

Container #4 at the facility has encountered a circuit breaker issue, and our on-site technicians are actively working to resolve it.

Thank you for your patience and understanding.
Posted Aug 06, 2025 - 21:08 UTC
This incident affected: North Dakota, United States.