OH2 Site Maintenance

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Sep 27, 2023 - 15:56 UTC

Identified

We will have occasional outages over the next 2 hours as the filters on our containers are cleaned.
Posted Sep 26, 2023 - 19:14 UTC
This incident affected: Ohio 2, United States.