Nebraska 2 - Scheduled Power Curtailment

Incident Report for Compass Mining

Resolved

This incident has been resolved.
Posted Aug 08, 2025 - 05:00 UTC

Identified

The local power authority has issued a notice to curtail due to high loads in the area due to the hot weather and low wind forecast. The mining facility will power down between the hours of 11am - 7pm CST 08/07/2025. Our technicians will bring miners back online as soon as the curtailment period is complete. Thank you for your patience and understanding.
Posted Aug 07, 2025 - 16:00 UTC
This incident affected: Nebraska 2, United States.